imo we should ditch the new names
zighooville has several funcs that need to be integrated into the sdk itself
In ZigHooville:
<in funcs.cpp>
The starting units setup
- void PutInitUnits(int x, int y, int i)
Morale
D/N
Volcano animation funcs
- void SouthEastFlowAni ( int x, int y)
- void SouthFlowAni( int x, int y)
- void SouthWestFlowAni ( int x, int y)
- void SouthEastFlowStopAni ( int x, int y)
- void SouthFlowStopAni( int x, int y)
- void SouthWestFlowStopAni ( int x, int y)
Set all black tiles-border tiles as lava positive
Pie Resources
- InitPlayerResourcesToPie()
Func to see if the tile is passible (natural reasons)
- IsPassible( int x, int y)
also, zighooville has a new feature that allows cargo trucks cargo to be set. it requires a bit of modification to the sdk and would be best kept as a seperate struct for backwards compatibiltity, but put into any new code bases.
syntax:
struct VehicleInfoE unitSetx[] =
{ x relative to cc, y relative to cc , vech type, cargo (for convecs), direction ,cargo (for cargo trucks) , amount of cargo (for cargo trucks)},etc
not all the new maps tho. i don't want to release borehole or any of its varients atm.
zighooville has a mini-c++ tutorial in it and synatax for disators and a example for use of SetTimeTrigger
imo punwick or whatever punboy's working on needs a bit of work and debugging before release as part of the sdk