I understand what you are saying about everyone not speaking English. It is easy understanding coding coming from English as a first language. Unfortunately, you cannot (or at least should not code) in multiple languages. So if you are going to create source code readable by the widest audience, English makes sense. But whatever language is chosen, I think the variable and function names should be a healthy mix of being terse, precise, and reading similar to how you would naturally read from that language. Even if someone is learning English as a second language to program with, forming the variables in a way that makes sense in English will probably still be helpful to them.
When reading the class name SeekableStream, it makes more sense to me than StreamSeekable. While I like the argument that writing StreamSeekable makes it easier to find with Intellisense (or the non-Microsoft equivalent), the counter to this argument is that when I'm reading a block of code, I will recognize what SeekableStream is/does quicker than StreamSeekable. I'd look at other libraries outside of C++ as well and try to mimic their choice of wording. I think SeekableStream is used more so than StreamSeekable.
You shouldn't be using an interface without having done at least a little bit of reading and using appropriate documentation
I'm guilty of just trying to find the proper function in Intellisense and applying it and going back later to research if it isn't working as advertised, or I'm feeling like I need to know more about it because others will be using my code. Maybe this is lazy, but it is reality and happens all the time.
Another thought is to include the "Stream" part in the interfaces, but omit it from the derived classes. Perhaps the Reader/Writer part is enough to imply something is a stream.
I like this idea for FileReader and FileWriter. I think as a user, it doesn't actually matter that you are using a Stream to read the file into memory for me. I just care that you are providing me the contents of the File. If it starts to matter more, I'll be able to see the interface or base class attached to FileReader that is called Stream with a bit of investigation.
Anyways, whichever you the 2 you choose I think will work fine and be readable.
-Brett