Author Topic: all links go to forum home  (Read 1600 times)

Offline stillhere

  • Newbie
  • *
  • Posts: 7
all links go to forum home
« on: August 18, 2013, 01:11:42 AM »
like it says, any link someone writes in a post that i try to click simply sends me back to forum.outpost2.net.


last time i was around 2 years or so ago, but the latest i see in news is something from yesterday.  could this have anything to do with the recent server/forum/ xmpp post change?

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Re: all links go to forum home
« Reply #1 on: August 18, 2013, 04:08:57 AM »
Galactic changed our forum software from IPB to SMF. As a consequence URLs are now formatted differently. The URLs in old posts are now invalid and thus get redirected to the main page.

I suggest that a script is used to convert all links in forum posts automatically.

Offline Galactic

  • Administrator
  • Full Member
  • *****
  • Posts: 141
    • http://www.konker.net
Re: all links go to forum home
« Reply #2 on: August 18, 2013, 07:27:01 AM »
Give me a link to an example post
Take me to your leader! I bare the claws of a corndog.

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Re: all links go to forum home
« Reply #3 on: August 18, 2013, 10:59:21 AM »
http://forum.outpost2.net/index.php/topic,5313.0.html

Under "Setup" you'll find a link to a thread/post where NetFix can be downloaded.


And since we're already talking about bugs: The style sheet isn't always loaded.

Offline Galactic

  • Administrator
  • Full Member
  • *****
  • Posts: 141
    • http://www.konker.net
Re: all links go to forum home
« Reply #4 on: August 19, 2013, 06:48:02 AM »
Cool thanks. I don't think there is an easy way to update each forum post, but I think I can modify SMF to accept IPB style links. I will keep you posted.
Take me to your leader! I bare the claws of a corndog.

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Re: all links go to forum home
« Reply #5 on: August 20, 2013, 02:25:07 PM »
There seems to be a problem with the DNS. My comp fails to resolve most opu domains, including xmpp.outpost2.net, outpost2.net, www.outpost2.net. Right now forum.outpost2.net is working, but most times also fails.

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Re: all links go to forum home
« Reply #6 on: August 21, 2013, 02:35:51 AM »
People can post here without registration! And I cannot delete posts :(

Offline Galactic

  • Administrator
  • Full Member
  • *****
  • Posts: 141
    • http://www.konker.net
Re: all links go to forum home
« Reply #7 on: August 26, 2013, 06:05:50 AM »
The DNS problem is due to the fact outpost-universe.net has been registered by someone else and we do not have control over the domain anymore. Lev use to own it.
Take me to your leader! I bare the claws of a corndog.

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Re: all links go to forum home
« Reply #8 on: August 26, 2013, 08:26:31 AM »
The DNS problem is due to the fact outpost-universe.net has been registered by someone else and we do not have control over the domain anymore. Lev use to own it.
I think, that is not the explanation. As I wrote in my post earlier, the problems occur when I'm trying to connect to *.outpost2.net. Its getting better, though. I guess, its just taking really long for all the name servers to pick up the change of the opu dns.

Time to deal with more serious problems.