Author Topic: Hamachi, Thumbs Down!  (Read 2726 times)

Offline Peacemaker

  • Newbie
  • *
  • Posts: 4
Hamachi, Thumbs Down!
« on: August 27, 2011, 07:46:47 PM »
so me and a few buddies are trying to get down on some OP2 baby. well netfix doesnt work, hamachi wont work, and port forwarding isnt working. I am lost, and yes hamachi is at the top in advanced settings! port forwarding was working but we would loose connection with someone.   :angry:  

Offline Peacemaker

  • Newbie
  • *
  • Posts: 4
Hamachi, Thumbs Down!
« Reply #1 on: August 27, 2011, 08:09:12 PM »
allow me to go into detail.

Port Forwarding: set up the router for port forwarding. Then we used the serial way to join the game created, each time we tried to play someone would loose connection.

Netfix: for some reason it always says game join failed or something along thoughs lines. Maybe once or twice it actually worked. Now it doesnt work at all. Continuously get the game join failed.

Hamachi: I'm pretty sure I set everything up correctly, hamachi is at the top of advanced settings and It wasnt working. So I did some troubleshooting and forum reading on the internets. Changed some number from 9000 to 1000. Still didnt work.

I have windows 7 and the newest version of hamachi. the people trying to play have multiple versions of windows (not sure if that effects anything).

please help with this problem. I wish to reconnect with my teenage years and get down on some OP2  (thumbsup)   B)  ;)  

Offline Savant_Ace

  • Full Member
  • ***
  • Posts: 103
    • http://www.spitfire-sa.com/
Hamachi, Thumbs Down!
« Reply #2 on: August 27, 2011, 08:47:28 PM »
Can you give me some system details, like NIC models and mainboards. Its not likely that this is a software issue (assuming you've configured everything properly.) But I have been reading an interesting error cropping up with people using newer machines and Hamachi that might be related to the way some NICs utilize TOE.  

Offline Savant_Ace

  • Full Member
  • ***
  • Posts: 103
    • http://www.spitfire-sa.com/
Hamachi, Thumbs Down!
« Reply #3 on: August 27, 2011, 08:48:23 PM »
Router and other network hardware involved would be helpful as well. This might be antivirus and/or firewall related as well.
 

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Hamachi, Thumbs Down!
« Reply #4 on: August 27, 2011, 11:14:35 PM »
Quote
Port Forwarding: set up the router for port forwarding. Then we used the serial way to join the game created, each time we tried to play someone would loose connection.
What you are describing here is NetFix with port forwarding. The "serial" button is for NetFix.

Quote
Netfix: for some reason it always says game join failed or something along thoughs lines. Maybe once or twice it actually worked. Now it doesnt work at all. Continuously get the game join failed.
Assuming you did not use the "serial" button, what did you do here?

Offline Peacemaker

  • Newbie
  • *
  • Posts: 4
Hamachi, Thumbs Down!
« Reply #5 on: August 29, 2011, 04:23:18 PM »
netfix, we did exactly what it says on the website. Just open op2 multiplayer, click serial the rest is pretty much idiot free.

tried turning firewall off for all of these, with no success.

Port forwarding, well my buddy did the port forwarding thing. But when he set it up we used the serial way like we would if we did not port forward and it would work but someone would get dropped after a min or two.

I'm guessing hamachi is trouble considering some of us have windows 7.
When I create a game this way it says my IP is what hamachi assigned however the other players trying to join cannot see my game when they try to join.

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Hamachi, Thumbs Down!
« Reply #6 on: August 29, 2011, 06:17:31 PM »
If you can start the game and then get disconnected after a few minutes/seconds, thats probably a router issue. I.e. your (or your friends) router changes the ports while the UDP connection used by op2 is active.

You can try the latest "experimental" version of NetFix: http://forum.outpost2.net/index.php?showto...indpost&p=68986

Although it has the same filename which says "v3", it has some improvements.

Make sure that all players use that new NetFix. If you still have trouble, you should post the log files "log.txt" and "logHost.txt" (especially the one from the host) which NetFix saved to the op2 directory.

Offline Peacemaker

  • Newbie
  • *
  • Posts: 4
Hamachi, Thumbs Down!
« Reply #7 on: September 06, 2011, 01:38:41 PM »
I will try that TH300, the next time I can get anyone to play.

it is def a router/ hamachi issue or something because we can direct connect just fine when we are all on the same router.
« Last Edit: September 06, 2011, 01:39:52 PM by Peacemaker »

Offline Combine Crusier

  • Sr. Member
  • ****
  • Posts: 456
Hamachi, Thumbs Down!
« Reply #8 on: January 27, 2013, 03:07:51 PM »
I can't even join my own game through NetFix though plent of people can see it. We always get joining failed.

The logs displayed are this:

[NetFix] ProtocolIndex = 3
Warning: Could not bind to ForcedPort = 47800
[NetFix] GameServerAddr = 68.146.111.58:47800
Search for games: (AF:2) 68.146.111.58:47800
[NetFix] GameServerAddr = 68.146.111.58:47800
Hosted Game Search Reply: (AF:2) 68.146.111.58:47800
Sending join request: (AF:2) 71.162.56.220:47800
  Session ID: {15e311fe-c392-47d3-9635c56479a046b4}
[NetFix] GameServerAddr = 68.146.111.58:47800
Sending join request: (AF:2) 71.162.56.220:47800
  Session ID: {15e311fe-c392-47d3-9635c56479a046b4}
[NetFix] GameServerAddr = 68.146.111.58:47800
[NetFix] GameServerAddr = 68.146.111.58:47800
Search for games: (AF:2) 68.146.111.58:47800
Hosted Game Search Reply: (AF:2) 68.146.111.58:47800
Sending join request: (AF:2) 71.162.56.220:47800
  Session ID: {15e311fe-c392-47d3-9635c56479a046b4}
[NetFix] GameServerAddr = 68.146.111.58:47800
Sending join request: (AF:2) 71.162.56.220:47800
  Session ID: {15e311fe-c392-47d3-9635c56479a046b4}
[NetFix] GameServerAddr = 68.146.111.58:47800
[NetFix] GameServerAddr = 68.146.111.58:47800
Search for games: (AF:2) 68.146.111.58:47800
Hosted Game Search Reply: (AF:2) 68.146.111.58:47800

Also with the TCP/IP nobody can even see my game even though I've already setup a port opening in my router as the webpage on the site instructed for port forwarding (http://www.outpostuniverse.net/multiplayer.php) and I input the force and host Ip commands into the OP2 init file.
Fire at will!

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Hamachi, Thumbs Down!
« Reply #9 on: January 27, 2013, 04:07:53 PM »
I wrote a NetFix guide that covers some more aspects than the one on the website. Click here. However, that guide doesn't yet contain some recent discoveries:

- NetFix hosting will for many people only work if: 1. the host uses the ForcedPort option in outpost2.ini and forwards that port AND 2. all other players do not use the ForcedPort ini-option.
- its probably easier to do direct TCP/IP if you want to play against yourself. If that is not an option, set 127.0.0.1:<port> as the server ip+port and set this port as ForcedPort in outpost2.ini. The second instance of outpost2 will have to be started without that option, though. Maybe there is a way to use the opu game server instead of your local ip, but I don't know that.


EDIT (leeor_net): fixing broken links
« Last Edit: August 29, 2017, 03:40:37 PM by leeor_net »

Offline Combine Crusier

  • Sr. Member
  • ****
  • Posts: 456
Hamachi, Thumbs Down!
« Reply #10 on: January 27, 2013, 04:18:24 PM »
- NetFix hosting will for many people only work if: 1. the host uses the ForcedPort option in outpost2.ini and forwards that port AND 2. all other players do not use the ForcedPort ini-option.

I have used the Forcedport and forward port but people can see though not join.

- its probably easier to do direct TCP/IP if you want to play against yourself. If that is not an option, set 127.0.0.1:<port> as the server ip+port and set this port as ForcedPort in outpost2.ini. The second instance of outpost2 will have to be started without that option, though. Maybe there is a way to use the opu game server instead of your local ip, but I don't know that.

Well I don't want to play against myself I just can't figure out why other people can't see my game through TCP/IP even after I've forwarded the port in the modem.
Fire at will!

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Hamachi, Thumbs Down!
« Reply #11 on: January 27, 2013, 04:42:31 PM »
If you came on xmpp, I could help you analyze the issue. (not now, though)

Offline Hooman

  • Administrator
  • Hero Member
  • *****
  • Posts: 3961
Hamachi, Thumbs Down!
« Reply #12 on: January 27, 2013, 09:41:44 PM »
Quote
Warning: Could not bind to ForcedPort = 47800
That could be relevant. If the game can't bind to the port you've forwarded, there's no way to see any incoming traffic. Hence join attempts would fail.

But if you're running more than one instance of the game on the same computer, that will happen to all but the first instance. The question then, is which instance are you hosting from?

If you're only running a single instance, then something else has grabbed the port.



Thank you for the problem report.
 

Offline TH300

  • Hero Member
  • *****
  • Posts: 1425
    • http://op3game.net
Hamachi, Thumbs Down!
« Reply #13 on: January 29, 2013, 12:35:59 AM »
Another possible cause of errors is people using different versions of op2. So, make sure that every one has the recent version from our website. Furthermore, it may help if every one has the latest NetFix, which is NOT yet included in the op2 download on the website. You can get it by following the link in my NetFix guide.
« Last Edit: January 31, 2013, 08:20:07 AM by TH300 »

Offline Arklon

  • Administrator
  • Hero Member
  • *****
  • Posts: 1129
Hamachi, Thumbs Down!
« Reply #14 on: January 30, 2013, 02:29:05 PM »
Quote
Another frequent cause of errors is people using different versions of op2.
The game will give you a specific error about game versions being mismatched in that case.

Offline Truewolf12

  • Newbie
  • *
  • Posts: 9
Hamachi, Thumbs Down!
« Reply #15 on: March 15, 2013, 07:11:09 AM »
about hamachi, it failed me as well. apperintly theres an unsolved problem with it disconnecting windows 7 users every few minutes.

Offline Truewolf12

  • Newbie
  • *
  • Posts: 9
Hamachi, Thumbs Down!
« Reply #16 on: March 15, 2013, 07:16:03 AM »
i too tryed setting the prority or whatever changeing the pre described numbers did, and it didnt help. this is a long, unsolved problem, i had to uninstall hamachi to be able to use internet agin