Outpost Universe Forums

Off Topic => General Interest => Topic started by: lordpalandus on June 04, 2018, 07:01:47 PM

Title: OPU Stability
Post by: lordpalandus on June 04, 2018, 07:01:47 PM
Is it just me, or is other people having troubles accessing OPU.

If I try to go to the main page (Home), the site appears offline. While writing this all the emoticons has boxes with X in it.

I can sometimes reach OPU by going to my forum post for my game, and sometimes it declares its offline anyway.
Title: Re: OPU Stability
Post by: leeor_net on June 04, 2018, 07:11:33 PM
Not having any issues seeing the rest of the website.

Galactic recently upgraded the server to an SSD and updated the operating system to CentOS 7 (from 6)... it's no surprise that there are a few glitches.

I've noticed the emoticons as well -- it's intermittent for me. But I'm glad I'm not the only one experiencing it.

I'll let Galactic know there are some hiccups but all should be well within a couple of days.

Sorry about the disruptions!
Title: Re: OPU Stability
Post by: Vagabond on June 04, 2018, 07:52:44 PM
I had difficulty accessing the website on Sunday for a while.

Title: Re: OPU Stability
Post by: Hooman on June 05, 2018, 10:09:15 AM
I think the update might have been done on Sunday. I'm actually not certain since I didn't find out until after it was done.

Maybe the interruptions were caused by the upgrade. Might also be some caching and content delivery network delays after the upgrade.

In other news, I've noticed the forums are a lot more responsive now. Things were getting pretty sluggish about a week back, with pages often hanging in a half loaded state. I'm pretty happy that's been fixed.

I'll keep an eye out for emoticon issues. If the problem persists, feel free to post again.
Title: Re: OPU Stability
Post by: lordpalandus on June 05, 2018, 11:34:01 PM
Well, I couldn't get onto OPU for most of today. Tried in the morning, afternoon, and evening, and kept getting The Page cannot be displayed errors. At 11:30Pm (my time), I finally have been able to get to OPU without errors.

Emoticons are still down and the main page "Home" next to the Outpost 1 at the top, still is giving me The Page cannot be displayed error.
Title: Re: OPU Stability
Post by: Hooman on June 06, 2018, 05:05:50 PM
Might be DNS issue. I'm not too sure what to suggest doing.

I assume other websites still loaded fine at those times?
Title: Re: OPU Stability
Post by: White Claw on June 06, 2018, 06:36:58 PM
As a data point, I haven't had any problems accessing the site...up to this point, anyway. We'll see if I just jinxed myself.
Title: Re: OPU Stability
Post by: leeor_net on June 06, 2018, 06:42:05 PM
I'm not experiencing these issues either.

I would suggest trying a flush of your local DNS cache just to rule that out as a possibility. To do so, click on the Start button, type in cmd, right click on the command terminal shortcut and click Run As Administrator. Click on Allow then when the terminal window opens enter ipconfig /flushdns and press enter. This will flush your DNS cache.

It's not an end-all-be-all solution but it does sometimes fix issues like this.

That stated, it could be a DNS issue with your ISP or with the server not having fully propagated across the 'net though usually that sort of things happens within 48 hours...
Title: Re: OPU Stability
Post by: lordpalandus on June 06, 2018, 08:25:48 PM
The only site I've had issues with is this one, and only after the site update.

Usually I cannot even visit the site in the morning/afternoon, and it only allows me to visit it at night (8pm my time+).

Other details:

1. I notice that the http is not a https. I can't remember if it was https before the update or not.

2. I'm running internet explorer.

Title: Re: OPU Stability
Post by: Hooman on June 07, 2018, 02:24:50 AM
Hmm, I just noticed this while checking the Wiki:
wiki.outpost2.netís server IP address could not be found.

Seems the site allows either http or https. Links appear to default to whatever protocol you are already using. I suppose update your bookmark if you want to use https.
Title: Re: OPU Stability
Post by: leeor_net on June 07, 2018, 06:59:53 AM
Odd. I'm still not experiencing any of these issues (and the emoticons thing has completely cleared up).
Title: Re: OPU Stability
Post by: Hooman on June 08, 2018, 08:25:29 AM
I checked again last night, found the wiki was working, but then the forums were not working. I have since been experiencing some intermittent connectivity problems. It appeared to be a DNS issue.

I'm a little rusty on DNS issues, so I may need to do a bit of reading before I can figure out what's going on.

From what I've recorded in the past, the IP address of the site has changed, which makes sense during a server upgrade. Perhaps this is related to the time required for DNS changes to propagate. Though I would assume that's a one-time break period, of differing lengths depending on where you are on the internet, and not some intermittent issue. So basically I don't really know what's going on at this point.
Title: Re: OPU Stability
Post by: lordpalandus on June 08, 2018, 10:51:53 AM
Well the site allowed me to log on during the day, so that is a start towards improvement.

Emoticons are still down and so is the main page with all the news.

Also for shiz and giggles, I tried visiting the site on Safari, Firefox, Chrome, and IE, and all of them have the same issues; a cannot find the page problem for the News and no emoticons in the posting replies to a thread.

So it doesn't look like something I can easily solve on my end.
Title: Re: OPU Stability
Post by: lordpalandus on June 12, 2018, 02:15:50 PM
Well, I can visit the site and the frontpage news from my Sister's house, about 30 minutes from where I am, but I'm still suffering intermittent issues here.

I flushed the DNSCache, and it had no effect, despite stating that it successfully flushed the Cache.

Sometimes the site lets me visit my game page here, and other times it states the page cannot be found and troubleshooter keeps mentioning the DNS Cache, which I flush after seeing the error and I still get the error.

Not sure how to proceed here.
Title: Re: OPU Stability
Post by: leeor_net on June 12, 2018, 03:53:25 PM
Are you making sure that you're prefixing everything with https:// vs http://?

I'm just grasping at straws here. It's odd that you'd be experiencing issues when I haven't seen it on any of my machines between home and work. I even remoted into a couple of machines out in NJ and I'm not having any issues there either?
Title: Re: OPU Stability
Post by: lordpalandus on June 12, 2018, 04:50:10 PM
Tried both, no dice on using the Home page. Here is a screenshot of the error and the link at the top of the page, for both attempts.

The third image is what happens when I hit troubleshoot.

The fourth image is proving that I did ipconfig /flushdns properly.

All screenshots taken within the past 10 minutes.

Title: Re: OPU Stability
Post by: leeor_net on June 12, 2018, 07:17:49 PM
My first thought was Internet Explorer... maybe that's it? No, it works fine on IE, Edge and Chrome on my PC.

That your network troubleshooter is suggesting a DNS issue says it might just be your ISP. But again, I'm just shooting in the dark here, I really want to help you get it working right.

It's also weird that you're only experiencing it on OPU.
Title: Re: OPU Stability
Post by: lordpalandus on June 13, 2018, 10:26:05 AM
It might be my ISP. I can access all functionality of OPU on my sister's internet, who has a different ISP than I do. And I tried several different browsers, and all of them had the same issues, so the only link that is the same for all, is the ISP or the router.

However, as I'm typing this, the emoticons have come back, so maybe the issue is resolved. Yep, only OPU is the issue.

EDIT: I can visit the homepage again. So it may be fixed. I dunno, as I don't think anything on my end fixed it.

If the issue returns, I'll post again.
Title: Re: OPU Stability
Post by: leeor_net on June 13, 2018, 07:05:48 PM
Sounds good. Fingers cross! :D
Title: Re: OPU Stability
Post by: Hooman on June 15, 2018, 05:31:05 AM
Sounds like a DNS error caused by bad data somewhere out on the internet. Depending on which server resolves your query, you could get a name lookup error. Different ISPs will likely query different servers. This should get fixed over time as DNS entries are expired/updated. Though it has taken longer than expected for things to settle.

I checked a couple days ago, and found the wiki was giving DNS errors. I went to post about it here, but then the forums were giving DNS errors. Currently everything is working for me.

I'm kind of hoping the trouble is over now, though I'll be checking on the various services periodically for the next little while.